错误代码0x84B20001怎么解决?

作者:小编 评论:0

解决拒绝访问升级的问题,访问升级的办法有很多种,看一下有那种方法适合自身的情况。


解决拒绝访问升级的问题1、


升级pip过程中报错:PermissionError: [WinError 5] 拒绝访问。: 'c:\programdata\anaconda3\lib\si……

##解决办法:


修改python.exe文件和python所在文件夹的权限,User赋予完全控制


解决拒绝访问升级的问题2、以管理员权限运行程序即可。


解决拒绝访问升级的问题3、全面升级HTTPS访问


全面升级HTTPS访问

HTTPS是什么?

HTTPS(全称:Hyper Text Transfer Protocol over Secure Socket Layer),是以安全为目标的 HTTP 通道,简单讲是 HTTP 的安全版。即 HTTP 下加入 SSL 层,HTTPS 的安全基础是 SSL ,因此加密的详细内容就需要 SSL。(节选自百度百科)

目前,一半以上的网站都已经开通了 HTTPS 加密,Chrome 和 Firefox 等现代浏览器均表示即将把 HTTP 访问的网站标记为不安全的网站。因此,开通了 HTTPS 的证书,将具体过程记录在本文中,以免忘记,因为三个月后我要给证书续期。


解决拒绝访问升级的问题4、该方法可用于pip install 库的拒绝访问问题.








解决拒绝访问升级的问题5、Python 之 pip拒绝访问.




起因




在我使用pip安装第三方库的时候,控制台提示我升级pip版本




You are using pip version 9.0.1, however version 10.0.1 is available.




You should consider upgrading via the ‘python -m pip install –upgrade pip’ command.




很显然,需要使用这样的指令:python -m pip install --upgrade pip




当时脑子短路的我这样写到:pip install --upgrade pip,并自信地回车了。然后就没有然后了……




解决办法




使用下面指令就可以恢复了,很是开心




python -m ensurepip




Requirement already satisfied: setuptools in d:\programs\python\python36\lib\site-packages




Collecting pip




Requirement already satisfied: packaging>=16.8 in d:\programs\python\python36\lib\site-packages (from setuptools)




Requirement already satisfied: appdirs>=1.4.0 in d:\programs\python\python36\lib\site-packages (from setuptools)




Requirement already satisfied: six>=1.6.0 in d:\programs\python\python36\lib\site-packages (from setuptools)




Requirement already satisfied: pyparsing in d:\programs\python\python36\lib\site-packages (from packaging>=16.8->setuptools)




Installing collected packages: pip




Successfully installed pip-9.0.1

我要评论 0条评论
说点什么吧
  • 全部评论(0
    还没有评论,快来抢沙发吧!